network sites: arcadespot.com | animejolt.com
+ Reply to Thread
Results 1 to 8 of 8

Thread: ndsi question

  1. #1
    Member
    Join Date
    Jan 2008
    Location
    Mexico
    Posts
    75

    Default ndsi question

    do flash carts work on the new dsi?

  2.    
  3. #2
    Elite Poster
    Join Date
    Nov 2008
    Location
    Cabramatta
    Posts
    419

    Default

    well.. dont think i should be talking about this..
    but.. flash carts that work for the ds dont work on dsi
    there are flashcarts specifially made for dsi.. such as acekard 2i, dstti.. i think there called..

    i also know the flashcarts that work on japanese dsi wont work on european ones..
    and that flashcarts are permanently banned from japan.. so yeah

  4. #3
    Member
    Join Date
    Jan 2009
    Posts
    39

    Default

    Actually that's not true, the acekard 2i and dstti - which were the one's that worked on the Japanese dsi DO work on the new dsi in the us and europe, however there is a new update around dubbed 1.4 that I'm not sure about. Also phanboi...only the R4 was banned in Japan not the other flash carts.

  5. #4
    Banned
    Join Date
    Mar 2009
    Location
    I Live In My World
    Posts
    227

    Default

    Also By the way,theres the best new DSI Card called "ITOUCH Ds"
    Its New And Especially made to work on the old ds,the new ds,and the Dsi.......
    For the cheats you can go on google and download cheat.dat for the cheat or rls.dat....xD
    its awesome!

  6. #5
    Member
    Join Date
    Sep 2007
    Posts
    64

    Default

    Get yourself an Acekard 2i and install the latest AKAIO firmware (google it). It works miles ahead of the official firmware in terms of compatibility. All current DSi's come with 1.3 firmware which is supported. If you want to take that dive do NOT update! Also you can get a Acekard for $10-15

  7. #6
    Senior Member
    Join Date
    Jan 2008
    Posts
    100

    Default

    What do you mean flash carts are completly banned from japan?

    If I get a flash cart that works with the DSi could I flash the firmware to allow older flash carts?
    Without the ability to run 3rd party software, a PSP is not a PSP!

    PSP Firmware History
    Moderator: http://psphomebrew.net
    http://psp-spot.com
    Admin: http://operation420.net/forum

  8. #7
    Member
    Join Date
    Sep 2007
    Posts
    64

    Default

    Quote Originally Posted by MPG187 View Post
    What do you mean flash carts are completly banned from japan?

    If I get a flash cart that works with the DSi could I flash the firmware to allow older flash carts?
    lol man you are on a roll. Read one post down from that. R4s are the only card banned due to its huge popularity.

    There is no card currently capable to put a customized firmware on a DSi. And why would you want to have a working DSi card enable a non working DS flash card? Nintendo patched those holes for a reason...

    Wouldn't you want a flash cart that WORKS for the DSi out of the box? *head explodes*

  9. #8
    Senior Member
    Join Date
    Jan 2008
    Posts
    100

    Default

    I don't want to get a new one. I don't want my old ones to be useless.

    The reason they patched the wholes is because they suck.
    Without the ability to run 3rd party software, a PSP is not a PSP!

    PSP Firmware History
    Moderator: http://psphomebrew.net
    http://psp-spot.com
    Admin: http://operation420.net/forum


 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts