network sites: arcadespot.com | animejolt.com
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1
    ON3
    ON3 is offline
    Senior Member
    Join Date
    Mar 2010
    Location
    Screwston,TX
    Posts
    113

    Default Which Flashcart is the best for DSi

    Wow today at school I bought a DSi ver.1.3u for 40 bucks and it included the charger, a blue case and a pokemon game man Im lucky. Anyways I wanted to know which flashcart should I buy 2d51 suggested to get a acekard 2i what do yall guys think I sould get?

    Ipod Touch 1G: J-Broke 3.1.2
    Psp 1000:5.50 GEN-D3
    Had a DS Lite:R4 SDHC then sold it n now i have a DSi:Acekard2i
    Wii:Ver:4.1 w/Homebrew Channel

  2.    
  3. #2
    Spot Veteran
    Join Date
    Sep 2009
    Location
    In your dreams
    Posts
    607

    Default

    Does it really worth it to buy a DSi after the 3DS is announced and will be out this or next year? Just askin here.
    PSP Slim & Lite 2001 (Limited Edition God of War Pack)
    5.50 GEN-D3 2GB 8GB
    FW History: 5.03 > 5.50 > 5.00 M33-4 > 5.00 M33-6 > 5.50 GEN-A(Brick) > 5.00 M33-4 > 5.00 M33-6 > 5.50 GEN-D2 > 5.50 GEN-D3 <=> 5.00 M33-6
    PROUD PINOY!
    Turning from a noob user, to a noob dev.

  4. #3
    Retired
    Join Date
    May 2010
    Posts
    4,568

    Default

    Quote Originally Posted by RNB_PSP View Post
    Does it really worth it to buy a DSi after the 3DS is announced and will be out this or next year? Just askin here.
    Meh, he already bought it. Why wait another year when he could get a DSi for fourty dollars?

  5. #4
    ON3
    ON3 is offline
    Senior Member
    Join Date
    Mar 2010
    Location
    Screwston,TX
    Posts
    113

    Default

    I think it was worth it I don't want to wait another year to buy that 3D DS (plus where would you find someone who will sell it that cheap) then I would have to wait for a hack for it. Just asking which flashcart should I get
    Last edited by ON3; 05-24-2010 at 07:14 PM.

    Ipod Touch 1G: J-Broke 3.1.2
    Psp 1000:5.50 GEN-D3
    Had a DS Lite:R4 SDHC then sold it n now i have a DSi:Acekard2i
    Wii:Ver:4.1 w/Homebrew Channel

  6. #5
    Senior Member
    Join Date
    Dec 2007
    Location
    Searching - Please Wait...
    Posts
    192

    Default

    I would reccomend an Acekard 2i seems compatible with most homebrew i have so, get yourself an Acekard 2i
    PSP History:
    (Full History)
    Slim psp: 3.71--->Bought datel tool battery --->Made magic memory stick via program <pc>--->3.71m33-2--->3.71m33-3--->3.71m33-4--->
    Bricked--->Pandora to 3.71OFW---->Nand backup---->Pandora to 3.71m33---->3.80m33-5---->3.90m33-2---->Full brick messing in flash---->downloaded new pandora memory stick creator---->pandora to 3.80m33-5---->3.90m33-2----->Waited a LONG while...----->5.00m33-6--->5.50GEN firmware--->Something went seriously wrong--->Pandora back to 5.00m33-4--->5.00m33-6--->IDStorage Corrupt--->Repaired with a PHYSICAL nand restore--->3.71m33-2--->5.00m33-6--->5.50GEN-D2 Correctly Installed this time :P --->And finally randomly switching between peoples themes

  7. #6
    ON3
    ON3 is offline
    Senior Member
    Join Date
    Mar 2010
    Location
    Screwston,TX
    Posts
    113

    Default

    Thanks user1690 Im going to tell my friend to order it

    Ipod Touch 1G: J-Broke 3.1.2
    Psp 1000:5.50 GEN-D3
    Had a DS Lite:R4 SDHC then sold it n now i have a DSi:Acekard2i
    Wii:Ver:4.1 w/Homebrew Channel

  8. #7
    Spot Veteran
    Join Date
    Dec 2008
    Location
    Proxima Centauri
    Posts
    754

    Default

    I can back that up
    AK2i is great, i've installed it on two of my cousin's DSi's, and it works great!
    BUT! if you are getting a new DSi, or recently updated your old one... the AK2i is NOT compatible with the new ofw 1.4 or 1.4U UNLESS, you update the AK2i
    But you need the AK2i on a working DS (any DS) indorder to update it's FW to be compatible with the DSi OFW 1.4X
    Make sense so far???

    My cousin's both had 1.4U already, so i updated the AK2i FW from my sister's DSlite...

    Reply if you have any Q's

    EDIT: Sorry i read you have 1.3, disregard the above...
    Now, when you install your AK2i FW, just update the AK2i FW, then update the DS to 1.4X and you should be OK
    Last edited by Anonymous Blah; 07-13-2010 at 11:34 PM.




  9. #8
    Junior Member
    Join Date
    Jul 2010
    Posts
    4

    Default

    Acekard2i
    Works on: DS Phat, DSlite, DSi, DSi XL

    Pros

    Great compatibility w/ AKAIO firmware
    Inexpensive
    Supports large memory

    Cons

    Few extras to enjoy
    Compatibility has been on the decline with less frequent fixes for AKAIO

    Overall: Not bad, not the best, but worth a purchase if you can't afford the other carts.

    Supercard DSTwo
    Works on: DS Phat, DSlite, DSi, DSi XL

    Pros

    Near flawless compatibility with very few updates required
    Built in GBA emulator
    Great interface
    Supports large memory

    Cons

    Still early in market life
    GBA emulator is very sub-par so far
    Many promised features have not come to light yet
    $35 price tag

    Overall: Better than the Acekard2i,This is easily the best cart for a DSi owner.

  10. #9
    Spam Buster
    Join Date
    Sep 2007
    Location
    Nottingham, Nottinghamshire, UK
    Posts
    722

    Default

    isn't there an R4? i've been told there good?
    Honey Badger don't give a sh*t!

  11. #10
    Spot Veteran
    Join Date
    Dec 2008
    Location
    Proxima Centauri
    Posts
    754

    Default

    R4 is somewhat outdated and is not DSi Compatible
    AK2i is the way to go





 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts