network sites: arcadespot.com | animejolt.com
+ Reply to Thread
Results 1 to 4 of 4
  1. #1
    Senior Member
    Join Date
    Dec 2007
    Location
    Searching - Please Wait...
    Posts
    192

    Default LCD Screen Issues

    I seem to be full of damn problems today.

    I have a LCD Cibox Monitor and it constantly flickers briefly while playing a game, any idea why?

    For some reason my LCD supports refresh rates (I heard LCD's didnt need this) so i've been tweaking with it in hope of solving my problem, Native (and minimum) refresh rate is 60Hz and Maximum is 75Hz, none of those settings solve my problem when playing some games.

    The problem in detail:

    I'll run a game for about 5minutes and the screen will just flicker (not on and off, just like a quick flash, a very quick one) and will continue to do so until i stop playing, this has started becoming an annoyance and i wish to know howto solve it.

    Graphics card details copied directly from CCC (Catalyst control center)

    Primary Adapter
    Graphics Card Manufacturer Powered by ATI
    Graphics Chipset ATI Radeon HD 4800 Series
    Device ID 9440
    Vendor 1002

    Subsystem ID 2267
    Subsystem Vendor ID 1787

    Graphics Bus Capability PCI Express 2.0
    Maximum Bus Setting PCI Express 2.0 x16

    BIOS Version 011.013.000.002
    BIOS Part Number 113-BA07XXXX
    BIOS Date 2009/01/05

    Memory Size 1024 MB
    Memory Type GDDR5

    Core Clock in MHz 780 MHz
    Memory Clock in MHz 925 MHz
    Total Memory Bandwidth in GByte/s 118.4 GByte/s

    All settings in CCC as far as i can see are correct, as are the settings within windows itself.

    Help?

    -Thanks in advance

    -Pissed off Cspot user.
    PS:
    Games attempted to be run but problem eventually occurs:
    GTA IV - STEAM Copy
    DOOM 3 - Retail
    Quake 4 - Retail
    Havent tried any of my other games as of yet.
    PSP History:
    (Full History)
    Slim psp: 3.71--->Bought datel tool battery --->Made magic memory stick via program <pc>--->3.71m33-2--->3.71m33-3--->3.71m33-4--->
    Bricked--->Pandora to 3.71OFW---->Nand backup---->Pandora to 3.71m33---->3.80m33-5---->3.90m33-2---->Full brick messing in flash---->downloaded new pandora memory stick creator---->pandora to 3.80m33-5---->3.90m33-2----->Waited a LONG while...----->5.00m33-6--->5.50GEN firmware--->Something went seriously wrong--->Pandora back to 5.00m33-4--->5.00m33-6--->IDStorage Corrupt--->Repaired with a PHYSICAL nand restore--->3.71m33-2--->5.00m33-6--->5.50GEN-D2 Correctly Installed this time :P --->And finally randomly switching between peoples themes

  2.    
  3. #2
    Spot Veteran
    Join Date
    Dec 2008
    Location
    Proxima Centauri
    Posts
    754

    Default

    I have seen this happen before...
    Maybe the games are in a different setting like PAL or NTSC
    Though i doubt that...

    try messing with the settings of the games, not the settings of the display or computer
    Also, does this only happen with games, is it also with normal use?
    And could you post the specs of the monitor, screen size, flat or CRT, etc...




  4. #3
    Senior Member
    Join Date
    Dec 2007
    Location
    Searching - Please Wait...
    Posts
    192

    Default

    Im no good with screen size measurements, and i dont have the instructions anymore, also i have tried tweaking ingame settings to no avail, the monitor is Flat LCD (or whatever its called). And it happens with games and normal use, HOWEVER with normal use, it'll only happen like, once every day...In a game...Well you know what happens, 5mins play and screen starts flickering
    PSP History:
    (Full History)
    Slim psp: 3.71--->Bought datel tool battery --->Made magic memory stick via program <pc>--->3.71m33-2--->3.71m33-3--->3.71m33-4--->
    Bricked--->Pandora to 3.71OFW---->Nand backup---->Pandora to 3.71m33---->3.80m33-5---->3.90m33-2---->Full brick messing in flash---->downloaded new pandora memory stick creator---->pandora to 3.80m33-5---->3.90m33-2----->Waited a LONG while...----->5.00m33-6--->5.50GEN firmware--->Something went seriously wrong--->Pandora back to 5.00m33-4--->5.00m33-6--->IDStorage Corrupt--->Repaired with a PHYSICAL nand restore--->3.71m33-2--->5.00m33-6--->5.50GEN-D2 Correctly Installed this time :P --->And finally randomly switching between peoples themes

  5. #4
    Senior Member
    Join Date
    Dec 2007
    Location
    Searching - Please Wait...
    Posts
    192

    Default

    I managed to solve the problem, of all the things i thought it wasnt. It was a driver issue, a driver update caused the problem so i rolled back to factory-state drivers and all is well.
    PSP History:
    (Full History)
    Slim psp: 3.71--->Bought datel tool battery --->Made magic memory stick via program <pc>--->3.71m33-2--->3.71m33-3--->3.71m33-4--->
    Bricked--->Pandora to 3.71OFW---->Nand backup---->Pandora to 3.71m33---->3.80m33-5---->3.90m33-2---->Full brick messing in flash---->downloaded new pandora memory stick creator---->pandora to 3.80m33-5---->3.90m33-2----->Waited a LONG while...----->5.00m33-6--->5.50GEN firmware--->Something went seriously wrong--->Pandora back to 5.00m33-4--->5.00m33-6--->IDStorage Corrupt--->Repaired with a PHYSICAL nand restore--->3.71m33-2--->5.00m33-6--->5.50GEN-D2 Correctly Installed this time :P --->And finally randomly switching between peoples themes


 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts